SOLVED – E: Unable to locate package php8.0-fpm & E: Package ‘php8.0-fpm’ has no installation candidate

Table of Contents

Error

This error comes while Installing PHP 8.0 with Nginx .

E: Unable to locate package php8.0 –

E: Package ‘php8.0-fpm’ has no installation candidate –

Solution

To solve this error run below commands in sequence –

Commands

Open terminal with command ‘ctr + alt +t’ , than give below command in terminal & press enter

sudo apt install software-properties-common

Terminal will appear like –

Than give command –

sudo add-apt-repository ppa:ondrej/php

Than terminal will appear like –

Then give Command –

sudo apt update
sudo apt install php8.0-fpm
sudo apt install php8.0-fpm libapache2-mod-fcgid

Then terminal will not give error & will install PHP 8 –

Hope so your error is Solved , Thank You for reading.